Thursday, March 3, 2011

MySQL Workbench on CentOS

Every once in a while I use MySQL Workbench. First is was only for Windows, then it was unstable and now it is very well usable. Or at least that is the situation when you run on a recent Ubuntu machine.

I'm now using CenOS 5.5 in a VirualBox VM to do some testing. Unfortunately the download site for MySQL Workbench has RPMs for RedHat 6 and Fedora Core 14 and some other platforms. No CentOS, No RHEL5, only the latest Fedora en RHEL.

So I downloaded the RHEL6 RPMs and tried to install them with yum localinstall, but that failed. So they are not backwards compatible with 5.5.

Turns out that CentOS/RHEL 5 doesn't have the required libraries to support MySQL Workbench.

And unfortunately CentOS 5.5 is still the latest release. So an upgrade to CenOS 6 is not yet possible.


  1. Yes Sir , even we are getting the same error. Is MySQL WorkBench compatible with CentOS???? Give some solution ASAP. We got dependencies error, we installed all the missing dependencies, but even after installing the dependencies we again got the dependency error. What to do?????

  2. Did you enable the epel repositories?

    For more info see also:

    And upgrading to CentOS 6 should result in a working situation.